Skip to content

System Requirements#

Installing and running WoltLab Suite requires a server or webspace with these capabilities:

System#

  • PHP-capable web server (Apache, nginx, lighttpd, Microsoft IIS, etc.)
  • PHP 7.2.24+ (PHP 7.4.21+ recommended)
  • MySQL 5.7.31+ or MariaDB 10.1.44+ with InnoDB- and MyISAM-Support

PHP Extensions#

The following PHP extensions are required:

  • ctype
  • dom
  • exif
  • json
  • hash
  • libxml
  • mbstring
  • pcre
  • pdo
  • pdo_mysql
  • zlib
  • Either gd or imagick (each with WebP support)

Web Browser#

To use the WoltLab Suite you need a current version of the web browsers Google Chrome, Microsoft Edge, Mozilla Firefox, Opera or Safari.