Zum Inhalt

Systemvoraussetzungen#

Für den Betrieb der WoltLab Suite wird ein Server bzw. ein Webspacepaket mit den folgenden Eigenschaften benötigt:

System#

  • PHP-fähiger Webserver (Apache, nginx, lighttpd, Microsoft IIS, etc.)
  • PHP 7.2.24+ (PHP 7.4.21+ empfohlen)
  • MySQL 5.7.31+ oder MariaDB 10.1.44+ mit InnoDB-Unterstützung

PHP-Erweiterungen#

Es werden die folgenden PHP-Erweiterungen benötigt:

  • ctype
  • dom
  • exif
  • json
  • hash
  • libxml
  • mbstring
  • pcre
  • pdo
  • pdo_mysql
  • zlib
  • gd oder imagick (jeweils mit WebP-Unterstützung)

Webbrowser#

Für die Bedienung der WoltLab Suite wird eine aktuelle Version der Webbrowser Google Chrome, Microsoft Edge, Mozilla Firefox, Opera oder Safari benötigt.